Wymagania serwera do instalacji CMS


Menu Główne » Instrukcja strony CMS » Administracja » Wymagania serwera do instalacji CMS


Strony internetowe z CMS opieramy o darmowy system MODX - strona producenta. Jest to w pełni wolne i darmowe oprogramowanie (licencja indentyczna jak np. licencja Linux, PHP itd.). Został on przez nas dostosowany i gruntownie przebudowany pod kątem przeciętnej realizacji www. W odróżnieniu od wersji bazowej oferuje wiele dodatkowych funkcji jak moduły Google Maps, galerie, sondy, newsletter, licznik, pola pomocne przy SEO, tłumaczenia itd. Została także użyta domyślna wersja polska od strony administratora.

Zgodnie z zaleceniem producenta, poniższa tabela przedstawia wymagania Państwa serwera co od 100% pewności, że aplikację uda się uruchomić. Oczywiście przed podjęciem zlecenia możemy nieodpłatnie testowo sprawdzić Państwa serwer, więc prosimy o uprzedni kontakt.

Z dotychczasowych realizacji chcemy zapewnić że w 99% procentach serwer naszego Klienta w pełni współpracował z naszym CMS jeśli chodzi o WYMAGANIA ZALECANE. Jeśl chodzi o WYMAGANIA MINIMALNE - praktycznie wszystkie. Zarówno jeśli chodzi o serwerownie krajowe jak i zagraniczne.


 

MINIMALNE WYMAGANIA


SYSTEM OPERACYJNY SERWERA WWW:

Linux x86, x86-64

Windows XP

Mac OS X

RODZAJ (TYP) SERWERA WWW:

Apache 1.3.x or Apache 2.2.x

IIS 6.0+

Zeus

lighthttpd

Cherokee

BAZA DANYCH:

MySQL 4.1.20 lub nowszy (wyklucza 5.0.51)

Domyślne kodowanie bazy utf8_polish_ci

SELECT, INSERT, UPDATE, DELETE, CREATE, ALTER, INDEX, DROP, CREATE TEMPORARY TABLES

InnoDB and MyISAM table types

PHP + MODUŁY PHP

PHP version 5.0+ (excluding 5.1.6/5.2.0)

Running as FastCGI

JSON

GD lib

Freetype

SimpleXML

safe_mode off

register_globals off

magic_quotes_gpc off

PHP memory_limit 24MB or more

ZALECANE WYMAGANIA


SYSTEM OPERACYJNY SERWERA WWW:

Linux x86, x86-64

Windows Server 2008

RODZAJ (TYP) SERWERA WWW:

Apache 2.2.x

IIS 7.0

BAZA DANYCH:

MySQL 4.1.20 lub nowszy (wyklucza 5.0.51)

Domyślne kodowanie bazy utf8_polish_ci

SELECT, INSERT, UPDATE, DELETE, CREATE, ALTER, INDEX, DROP, CREATE TEMPORARY TABLES

InnoDB and MyISAM table types

PHP + MODUŁY PHP

PHP version 5.3.3+

Running as FastCGI

zlib

JSON

cURL

Imagemagick

GD lib

SimpleXML

safe_mode off

register_globals off

magic_quotes_gpc off

PHP memory_limit 32MB or more

mod_rewrite on

 


 

Sklepy internetowe opieramy o skrypt PrestaShop. Jest to na tyle popularne oprogramowanie, że praktycznie każdy serwer dostępny na rynku spełnia wymagania instalacji. Wręcz brak możliwości zainstalowania tak popularnego oprogramowania na danym serwerze obniża reputację takiej firmy hostingowej. W zwiazku z tym nie będziemy tutaj podawać jakie mają być wymagania PrestaShop, bo łatwo je znaleźć w Internecie np.  http://www.prestashop.com/en/system-requirements